Galat di

dev-libs/icu

Sepertinya sedang ada perubahan versi yang menyebabkan Gentoo gagal memasang versi terbaru. Setelah saya cari tahu, ternyata kegagalan menemukan pustaka dari pake “dev-libs/icu”, sebuah paket internasionalisasi. Ternyata saya memasang versi baru “48” sedangkan yang lama versi “46”. Anehnya, ini tidak terdeteksi oleh “

revdep-rebuild

“.

Cerita pendeknya, ternyata saya harus mengompilasi ulang “

dev-libs/libxml2

“.

$ emerge -av dev-libs/libxml2

Galat di

media-libs/mlt

Sistem saya berusaha memasang “xulrunner” yang menggunakan MLT. Ternyata versi 0.7.2 dari MLT memiliki galat ketika mengompilasi dukungan Ruby. Maka cara sementara membetulkannya adalah dengan mematikan dukungan Ruby.

$ USE="-ruby" emerge -av media-libs/mlt

Saya lupa, buat apa, yah, dibutuhkan dukungan Ruby?