If you are using 9.10 like mine, there are few things that applications need to adapt.

1 G++ 4.4 will not include stdio automatically anymore

If you have these kind of error:

error: 'stdout' was not declared in this scope
error: 'fprintf' was not declared in this scope
error: 'fclose' was not declared in this scope
... and so on.

The fix is to include cstdio, meaning:

#include <cstdio> 

2 Unharmful warning message from CMake

CMake now wants the application set the minimum CMake version. Add this:

cmake_minimum_required(VERSION 2.6)