KDE4 now resides in Debian Unstable with the version number 4.2.2 for stable release. If you are a convert like me (using GNOME), it poses no problem. But, the upgrade will stuck if you have KDE3 installed. To tackle the problem, you could upgrade the opposing KDE3 applications to KDE4, or remove it. Then, install <code>kde-minimal</code>.