Beberapa waktu lalu sedang ramai-ramainya bug OpenSSL CVE-2014-0160 aka HeartBleed yang ditulis oleh rekan saya JP (http://staff.blog.ui.ac.id/jp/2014/04/10/galat-heartbleed-pada-openssl/), Sehingga mengharuskan upgrade pada sisi server. Namun diwaktu itu juga mysql pada sistem pun ikut terupgrade ke versi MySQL 5.6.17-1~dotdeb.1 yang menyebabkan error : mysql_connect(): Headers and client library minor version mismatch.

Permasalahan :

Ternyata setelah ditelusuri error ini terjadi dikarenakan PHP yang sudah terkompilasi dengan sistem terhubung dengan MySQL versi lama sebelum ditingkatkan ke versi yang lebih baru.

Cara Mengatasi

Cara mudah untuk mengatasi error ini adalah dengan install php5-mysqlnd :
sudo apt-get install php5-mysqlnd

Terima kasih untuk bapak Tonny.

Referensi :
http://stackoverflow.com/questions/10759334/headers-and-client-library-minor-version-mismatch
http://www.dotdeb.org/2014/04/04/about-the-mysql_connect-headers-and-client-library-minor-version-mismatch-warning-2/

Print Friendly, PDF & Email